Ph bot can't enter the game (Managet - Testing both)


Hello, I can’t connect to the game. I formatted my computer yesterday. The problems started after that. Silkroad Launcher was opened but the start button was not visible. Although I can enter the game with PHBot from time to time, the game stays on the password entry screen and then disconnects. There is no screen at all at the moment. I’m about to go crazy. I need your support.

It is possible that agent server is down which is why you cannot connect. This happened a few months ago on TRSRO.

Try another gateway and see if that works.

It didn’t work. I could enter 1-2 times. I had too many pings and game drops afterwards. I cannot enter the game consistently. I can hardly get into the game without using a PH bot. The start button is not active most of the time. I suspect my internet connection is disconnected. I contacted my service provider but they say it’s okay. Could it be related to firewall? I did research but didn’t get any results. I have been playing this game for many years, but this is the first time I encounter such a problem. I bought a new modem and tried it, the result is still the same.

You’re IP banned.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.