Update ISRO on VPS

Hello everyone,

The guide says

“You will need to have the game installed so the bot can generate a database containing data from the games Media.pk2 and Data.pk2 files. After that, you may copy the iSRO.db3 and SilkroadR.db3 files to a VPS and launch the bot. If the game updates, you’ll need to copy the newly generated databases to the VPS.”

I’ve managed to run the phBot on my VPS using Ryan’s script.

My question is: Is there is a way to update Silkroad on the VPS itself?, instead of updating it on another machine and then copying the files on the VPS (Maybe fetching the Media.pk2/Data.pk2 from the isro servers on the VPS after an update?)

PS: I tried simply starting the launcher, but it crashes since my VPS doesn’t have a GPU. So it never gets to the updating phase.

Thank you for your help in advance.

Just run Silkroad.exe through Wine on the VPS.

I tried, but it keeps crashing before even showing the “Start” button

I didn’t have any issues before. You’d have to copy it over each time.

@abdelgad enable Data Execution Prevention aka DEP from This PC properties and add silkroad.exe to it then it will work

But I’m running ubuntu 18.04 on my VPS :confused:

That’s not a thing under Linux.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.