Town loop2

hello Ryan, im still having the loop issue that it doesnt do the town scipt even after i took the hotan script and added my script after it, the char keep cycling in the town doing the same script and never go to the training area… second i removed the town coordinates and removed the second hotan file from the bot folder but it buys nothing and goes directly to the training area, so i got 2 issues and cant get what i need to do normal town loop and then go to the training area!! please help fast

Delete your town folder and training area and start over. I’m not sure what you did to do that.

image add it to end of your town script it migght work

will do that when im home from work and give you feedback!! i did nothing… i just tried the normal script and char goes storage blacksmith to free trader to get the free potions then to training area and i wanted to buy horses and recovery pots so i used the hotan script from town folder and added my script after that, the char keep cycling in the town and never goes to training area… that what happened and i did nothing else

shal i do that while im recording the script or what?

If you’re recording a town script then yes you need to add it at the end. If the town script is already recorded you can manually edit the file by adding “DoScript” without the “” at the end of the file.

Nope, i didnt do town script and dunno how… I just took the script from hotan file in town folder and recorded my script over it but didnt work and char kept looping in the town

Ryan, i still have the same issue … If i make the normal script it goes to the training area after the free loop and doesnt buy horse or recovery kits or speed scroll and if i made another script starting with hotan script it keep rounding in town and never goes to the training area

wing 78-80.txt (2.3 KB)

Ryan, thats my script and i did normal town script but still got the same problem… what now? wont it buy what i want and work as i need?!!

ah btw, i removed the town folder but it shows up back itself everytime i open the phBot

If there is no solution for this!! How would i buy via clientless the horse and recovery kits?


Really? You must go near the npc to be able to shop. Dont you see town script file?

i took that dam town script file and made the loop over it and i had nothing so im trying everything!! will try to go close to the npc and make the command, lets see if it works

Edit, still the same problem… i started get pissed off from that!!


u are doing wrong

So whats the correct? Paste here the first part of any script you have before leaving the town or full script and i will take the town part and i will try it… I’ve done tried everything now

I looked at your script and I’m not sure what you were trying to do. Town script (inside the Town folder) is for only the town loop (buying/repairing). This contains “DoScript” at the end. Your normal script should not have any town command inside them. It simply walks from town to your training area.

One more thing: you have to walk to the NPCs before adding a command like “DoStorage” otherwise it will give you an error about not finding an NPC.

That means that if i removed hotan script and created new one it will auyomaticly stick with that? But i removed hotan free folder and left only script which makes it buys normal loop and still doing free script thats why im totally confused and been trying stupid things… Im stiil await for a real solution

Okay, i got that point… I just need to know the correct way making a script including normal loop instead of the free loop

It looks through every single script in the Town folder. The name of it doesn’t matter. So if you leave other ones in there it may still use them.

The “free” scripts are the ones with _r at the end of the name. It uses those instead if you are below level 70.

My chars are lvl 70 and they still using the free loop, how to use the normal