Silkroad Phbot monster preferences doesn't work

canavar tercihlerimde dev tercih et seçili bir şikilde bulunuyor.Fakat bana saldırı yapan bir dev canavar var ama phbot dev canavarı görmezden geliyor ve normal canavarlara saldırı yapıyor dev canavar benimle birlikte geziyor bunu anlamıyorum.

Which server?

TRSRO Harput bro. Frankly, it’s a very frustrating situation. The champion and the giant monster are attacking me, but my character does not attack the champion and the giant. They die thanks to abilities that bounce from normal monsters, but it takes a very long time. Very happy if you help.

Enable “attack lower monsters first”.

“attack lower monster first” closed.

Turn it on not off.

You misunderstood me, the character attacks normal monsters. It does not attack giant and champion monsters.

He doesn’t see the giant monsters, he acts as if the giant monsters don’t exist. It only attacks normal monsters. It ignores the monsters I tell it to prefer.

Koruma- canavar tercihlerini kontrol et bakalim

Okay. Let me explain this to you. He wants you to “turn it on”. You need to turn that on. Because there are two things to consider. Basically, it is better to attack lower monsters first because it takes too much time to kill stronger monsters and meanwhile “smaller” monsters attack your character. That option so to say “optimizes” your pot usage and avoiding your character to die. Imagine that you are trying to kill Giant Party and it takes about 2-3 minutes. At that time, lower monster count will increase and suddenly you will end up with 6 monsters around you and you will die. Therefore, normally you would kill smaller monsters first then go back to Giant Party. That option fixes it.
Now, the other scenario is that you have another party in your slot and you want to attack Giant Party first because if you don’t, the other party will do more damage and steal it from you. For this kind of situation you need to use “Monster Preferences”.
Now combining two of them which means activating “Attack lower monsters first” and adding Giant Party (in your case Giant) to monster preferences with “Prefer” option would solve the problem.
Note that you can add multiple monster type, or specific monster with Prefer options. Bot will decide according to order of your options.

1 Like

kardeşim resmini paylaştım hala kontrol et yazmışsın :slight_smile:


1st, I know what the kill little monsters tab does. I turned it off because it didn’t attack giant monsters, it was on before. Maybe the reason was the attack little monsters first tab so I closed it.
Secondly, I have been using this boat for a long time. This problem happened after the updates. Previously, it was attacking whichever monster type I chose first, but now it is ignoring it. so lies the character. While there are 4 giant monsters above me, the character goes and attacks the normal monster.

Could you share your config file? It is located inside “Config” folder of phBot folder.