[Plugin] SROMC v0.9.8 Mobile App (Android & iOS)

why doesn’t it work anymore

HTTP Error 503: Service Unavailable

Hello,

SROMC app causes extra costs on my personal server. So I’m looking for another server. It will be active again soon.

I do my best to keep the app free at all times.

Thanks.

Thank you for your interest, but we expect you to bring innovations to the application and fix the errors. Respects

It’s a free application made and paid for by a community member… you should not have any expectations. You should appreciate it’s made free in the first place

Hello,

I stopped playing Silkroad temporarily. You can report the error you get to me. Thanks.

Thanks. :handshake:

1 Like

I have completed the server migration. App and API currently working and no issue.

If you see a problem, please let me know.

2 Likes

Thank you!!

Hello @ILKERC :slight_smile:
For some reason I was only able to add one char to the app, but when I tried to add a second one, nothing was hapening after I entered the login details and clicked “Add”. After I restarted the app, the first char was gone as well and now I can’t add any chars (nothing happens when I enter login details and click “Add”). Android, Samsung Galaxy s22. Any ideas, what could be wrong? I don’t want to risk reinstalling the app as I read that I can only add a char to one app account, so if the first char was associated with the initial app account, I may not be able to add it to the new account I create after reinstalling the app :slight_smile:

Hello,

Thanks for feedback. I will look for this problem.

You can reinstall SROMC app and re-enter your character info. Your character will be re-paired.

Thanks.

I did some more testing… the ID and password are certainly good (tried 2 chars), because if I enter wrong information, I get a message that no characters are found with this information. I tried allowing all permissions (incl. location) for the app. Nothing helped. And there are not many settings in the app itself.
No rush - I understand that this is a “free time” project for you. But it really looked amazing (I was able to browse through the char menus while I still had one char added) and I look forward to being able to use it. If you would add more donate options than just BTC, I would surely send you a coffee or two :slight_smile:
P.S. My Android version is Android 13, Samsung One UI 5.1. (S901BXXU3CWAI).

“Thank you” is better donation :slight_smile:

Unfortunately there is no device where I can test the Android version of the application. I only run Android tests on the emulator. That’s why I can’t see any errors that occur/may occur on real devices.

If you can send me your “character name/server” information as a private message; i can check if the problem is from the app or the API.

Thanks.

I am not able to add my characters either. Tried two characters. OS Version Android 12. Tried reinstalling script and the app. Didn’t work :slight_smile:

I downloaded the plugin but it doesn’t load when clicking “reload” on the plugin tab. I downloaded other plugins that works fine. Only this wont load, any idea?

Hi, does the problem occur when adding the second character? I guess it’s time to release a new version for Android. :slight_smile:

Hi, where did you download the plugin? I have also received feedbacks from some users that 2 tabs (SROMC) appear when plugins are reloaded.

I think there is a problem with phBot. @Ryan

Thanks.

I downloaded it on your GitHub.
Is it compatible on TSRO?

Hello,

Yes, compatible with all versions of phBot running.

But there was an update about the plugins on the phBot side. There may have been a problem with supported plugins. I do not have detailed information about this.

in this case you would need to ask @Ryan to whitelist your plugin for it to be compatible with TSRO

The version on Github is already whitelisted. As long as you right click and save as it should load.

thanks mate for this amazing app but please we need notifications for rare drops and try also if u can to make a section for rare drop for all chars u open and please add kill mobs count and botting time to general info on app

It doesn’t load for me … I am using others plugins without a single problem but this one is not loading