phBot crash under Linux(wine)

Hi,

I encounter some bot crashes with Linux. I dont know If you are able to help or know something that could help.
I currently use a linux server to run some bots.
Within the last 2 days everything worked fine. But today one char keept crashing after the bot “Started”. Login, CharSelection and Spawning are working fine but after I or the bot itself push “Start Bot” wine/phBot just crash. This only appears at North Alexandria.
Maybe some bad server edits or more likely a wine thingy?

I tryed to delete the .json and db3 and “reset” the char config but nothing worked there. I just set my recall point to south Alexandria, that fixed the problem.


Crash Backtrace

I dont know if you can see something in this dump that could prevent this.

greetings
Delirus

Hm, it looks like it crashed at malloc which is a memory allocation function. Is it possible the system is out of memory?

Hmm… right now two other chars are crashed aswell, seems something is really weird there

That’s definitely enough memory. It’s definitely just Wine then. If you have that much memory why not spin up a KVM VM with Windows 7 or something and RDP into it?

Yes I guess this will be the best solution for the problem.
I tested a bit more and this only happens if a char is inside a town and starts the town script. If the bot is at the trainings place everything is working flawlessly. Just wired, because it worked fine for 2 days xD And I didn’t change the anything system/botsettings

Ok now I dont know whats going on anymore. Even the bot is crashing under a windows machine.
https://i.imgur.com/GHgE6tK.png but only 4/5 times. It worked for one attempt.

I tested to delete the whole configs again, but again nothing happened xD
https://i.imgur.com/0JoRTt4.png and new message appeard

Might want to use 21.6.9 for now then. I added a lot of new stuff so it’s possible something doesn’t work.

This crash thing happend to me at version 21.6.9 but @linux before some hours. Than I updated but also got crashes.
Just a question does Path Finding anthing town related? Or is this just static?

Yes, path finding is done during your town loop but it has been like that forever.

Not getting any crashes in town. What are the coordinates for your training area?

-168, -279 from Hotan. I tested it 5 times. it worked 4 times again and just as I was about to say somehow fixed it crashed again https://i.imgur.com/qrZ343C.png

1 Like

Ah ha yes it crashed for that and I have no idea why. Checking it out now.

It’s related to extracting files from the PK2 files. For now you can turn off collision detection. I believe this problem always existed but only happened when it took a while to load a region.

Hmm doesnt seems to be related to collision detection. I dont have this feature activated https://i.imgur.com/qwQTDDC.png
I started the bot multiply times to test it

You’re right. It’s that + path finding causing some weird problems that never occurred before. I’m working on it. Should have another update out soon once it’s fixed.

1 Like

Almost ready. Took a while because I had to rewrite how it requested paths from the server.

Seems to work fine. Now I can bot with my Linux machine again ;). thank you for your fast help.

EDIT: It works fine for hours now. I can imagin that this took a while to write. Glad we found it. It was just too strange that the bot was working for 2 days straight and than out of nowhere some crashes^^

Have a nice day

1 Like