Issues with connection via proxy works on sbot but doesnt on phbot testing 27.7.7

I am keep getting the following log entry if i use a proxy.
Connection was closed by the remote host, retrying
I ve already searched the form with this log entry
and i know its been mentioned by @Ryan that this is an ISRO issue due to connection limit etc.
Well i dont think this is the case because i made sure the proxy ip is used only on one character. and it is happening only on phbot. same issue doesn’t happen sbot for example. please see the screeshot from sbotand phbot below for comparison.

For this example, if close the sbot, log off the char and reopen it up the Phot to try again. and I ended up getting the same problem.

This issue so far happened 3 times on 3 different characters out of the 26.
The issue also disappears when i disable the proxy.

Could there be an edge case in the code that causing this issue in addition to what @Ryan mentioned?

Please find all the relevant data below.

image

image

[20:36:14] Data load status: 100%
[20:36:17] Connecting to the gateway server [110.234.18.163:15779] through 104.143.225.234:5241
[20:36:34] Connected
[20:36:35] Server capacity [Erebus] [Full]
[20:36:38] Login: Sending login credentials
[20:36:43] Login: Secondary passcode has been entered successfully
[20:36:44] Connecting to the agent server [110.234.56.123:22230] through 104.143.225.234:5241
[20:37:00] Connection was closed by the remote host, retrying
[20:37:01] Connecting to the agent server [110.234.56.123:22230] through 104.143.225.234:5241
[20:37:06] Connected
[20:37:07] World server traffic / C10
[20:37:07] Clientless: Retrying in 5 seconds

connecting fine when proxy is disabled.
image

and here right after the above, i used another proxy ip that was never used before and i ended up getting the same error.
image

Edit: I noticed that one of the party was in logging process with 6 of the chars. the char that i was having issues with was on another party. I disconnected the logging party and tried to see if that makes a difference. and it did. the char successfully logged in. but this is very odd. the proxy ip used on another party is completely different.
image

Can’t tell by the pictures but you could of been logging into different gateways servers on the two different bots

@DeRidder14 yea i thought of that but i selected a random one for the one with the issue. it always happens regardless of which gate away is used on phbot. besides its very odd that once i disable the proxy it works fine regardless of which gateway is used.