Genie Lamp DW v25.2.3

Hey there,

short info about latest testing version:
It is newly telling me that no lamp is found. It disables the genie quest right after this message. It happens when the quest is already done for the day. It does not happen if the quest can still be accepted.

  • v25.2.3
  • Coordinates: Donwhang Return Point
  • iSRO
  • Genie Quest is enabled. Daily Quest at NPC Bei Man in Donwhang is enabled and return is checked.
  • Genie Quest lvl 121-125

It worked in earlier versions like a charm.

Cheers

Problem still persists …


[23:49:53] Auto Quest: Walking to [Daily Quest Manager Bai Man]
[23:49:54] Script: Walking to 3549, 2069
[23:49:55] Script: Walking to 3549, 2077
[23:49:55] Script: Walking to 3556, 2084
[23:49:56] Script: Walking to 3563, 2089
[23:49:57] Script: Walking to 3569, 2095
[23:50:08] Auto Quest: [Genie’s Lamp] not found
[23:50:08] Auto Quest: Disabling quest [Genie’s Lamp]
[23:50:09] Script: Walking to 3569, 2095
[23:50:09] Script: Walking to 3547, 2084

Cheers

If it doesn’t exist in the NPC it has to disable it.

What means I have to re-enable this:

image

every day? Of course there is no lamp, if the daily quest is already done for the day … repeatable seems to be senseless in this matter then.

Cheers

I’m pretty sure that quest always exists in the NPC. It shouldn’t be disappearing after you complete it.

I have tested it just now. That’s the log if the quest is not done for the day:

[18:25:30] Bot started
[18:25:30] Auto Quest: Walking to [Daily Quest Manager Bai Man]
[18:25:31] Script: Walking to 3551, 2071
[18:25:32] Script: Walking to 3549, 2073
[18:25:32] Script: Walking to 3550, 2078
[18:25:32] Script: Walking to 3557, 2085
[18:25:33] Script: Walking to 3564, 2090
[18:25:34] Script: Walking to 3569, 2095
[18:25:40] Auto Quest: Accepting quest [Genie’s Lamp]

Doing Town Script

Walking To Spot

Attacking

[18:30:53] Returning to town due to quest completed
[18:31:15] Auto Quest: Walking to [Daily Quest Manager Bai Man]
[18:31:16] Script: Walking to 3551, 2071
[18:31:16] Script: Walking to 3549, 2073
[18:31:16] Script: Walking to 3550, 2078
[18:31:16] Script: Walking to 3557, 2085
[18:31:17] Script: Walking to 3564, 2090
[18:31:18] Script: Walking to 3569, 2095
[18:31:30] Auto Quest: Getting quest reward [Genie’s Lamp]
[18:31:45] Auto Quest: [Genie’s Lamp] not found
[18:31:45] Auto Quest: Disabling quest [Genie’s Lamp]
[18:31:54] Auto Quest: Walking to [Homeless Genie]
[18:31:54] Script: Walking to 3569, 2095
[18:31:54] Script: Walking to 3562, 2088
[18:31:55] Script: Walking to 3553, 2084
[18:31:55] Script: Walking to 3544, 2084
[18:31:56] Script: Walking to 3536, 2079
[18:31:57] Script: Walking to 3536, 2070
[18:31:58] Script: Walking to 3543, 2064
[18:31:58] Script: Walking to 3546, 2065
[18:32:05] Auto Quest: Getting event quest reward
[18:32:09] Auto Quest: Quest already accepted or missing quest item [Hand the lamp]
[18:32:24] Returning to town due to path could not be found for quest return

Continues normally …

And that’s the log if the quest is already done for the day:

[18:36:34] Bot started
[18:36:53] Auto Quest: Walking to [Daily Quest Manager Bai Man]
[18:36:53] Script: Walking to 3565, 2024
[18:36:53] Script: Walking to 3564, 2033
[18:36:54] Script: Walking to 3564, 2042
[18:36:55] Script: Walking to 3564, 2051
[18:36:56] Script: Walking to 3563, 2060
[18:36:56] Script: Walking to 3560, 2069
[18:36:57] Script: Walking to 3560, 2078
[18:36:58] Script: Walking to 3563, 2087
[18:36:59] Script: Walking to 3570, 2093
[18:36:59] Script: Walking to 3571, 2095
[18:37:10] Auto Quest: [Genie’s Lamp] not found
[18:37:10] Auto Quest: Disabling quest [Genie’s Lamp]
[18:37:11] Script: Walking to 3571, 2095

Continues normally …

Both results in toggling the Yes into a No as mentioned above and the bot never tries to do the genie quest again.

My settings are as follows:

image

image

It was working before, this is why I was wondering this happens now.

Cheers

I’ll send you something to try. I completely rewrote how quests get checked which is why it’s not doing what you want.

https://mega.nz/file/OpYmnDyb#O4W-fJR5w9ZaU11UwM8EJuCXqFmZv1kZu4W5dKPCoeE

Sorry for not responding. Thx for the link. I will test it as soon as there is time. Im a bit in a hustle at the moment.

This is the one you want since I removed the old link.

https://mega.nz/file/y852ASQI#EjjqMaKVx0yHwYxqchATJP5SOmpFkOVr2R6DE1F_-l8

Unfortunately, I cannot really test the genie quest at the moment, because I used phbot Stable overnight and it worked (will switch to Testing again because of DLL issues on Ubuntu with Stable, there is something wrong, but I dont want to bother you with this one … error message is very bizarre, Testing is working though).

The version you sent me is not disabling the quest as described above, if the quest is already done for the day. So this part seems to be working now.

But I just noticed another issue which may be related to the genie issue: I have a character running in job cave doing quests as well. I enabled the hunter quests as follows:

I made a script from lvl spot to the NPC:
walk,-32752,-21759,-77,57
walk,-32752,-21759,-107,57
walk,-32752,-21759,-147,70
walk,-32752,-21759,-172,57
walk,-32752,-21759,-192,57
walk,-32752,-21759,-214,59
walk,-32752,-21759,-236,83
walk,-32752,-21759,-270,66
walk,-32752,-21759,-293,66
walk,-32752,-21760,-316,66
walk,-32752,-21767,-321,66
walk,-32752,-21788,-317,66
walk,-32752,-21807,-319,67
walk,-32752,-21825,-319,83
walk,-32752,-21861,-318,57
walk,-32752,-21879,-318,57
walk,-32752,-21897,-321,67
walk,-32752,-21904,-320,70
quest,Hunter Union Representative Kapado,Proof of Strength 1 (Hunter)

If the quest is finished, everything is working fine. It notices the finished quest and goes to the NPC, but it is not taking the reward and thus it is not re-accepting it:
[22:54:40] Quest: [Proof of Strength 2 (Hunter)] has been completed
[22:54:40] Script: Walking to -21759, -77
[22:54:44] Script: Walking to -21759, -107
[22:54:46] Script: Walking to -21759, -147
[22:54:50] Script: Walking to -21759, -172
[22:54:52] Script: Walking to -21759, -192
[22:54:53] Script: Walking to -21759, -214
[22:54:55] Script: Walking to -21759, -236
[22:54:57] Script: Walking to -21759, -270
[22:55:00] Script: Walking to -21759, -293
[22:55:02] Script: Walking to -21760, -316
[22:55:04] Script: Walking to -21767, -321
[22:55:04] Script: Walking to -21788, -317
[22:55:06] Script: Walking to -21807, -319
[22:55:08] Script: Walking to -21825, -319
[22:55:09] Script: Walking to -21861, -318
[22:55:12] Script: Walking to -21879, -318
[22:55:14] Script: Walking to -21897, -321
[22:55:15] Script: Walking to -21904, -320
[22:55:38] Script: Walking to -21904, -320
[22:55:38] Script: Walking to -21897, -321
[22:55:38] Script: Walking to -21879, -318
[22:55:40] Script: Walking to -21861, -318
[22:55:41] Script: Walking to -21825, -319
[22:55:44] Script: Walking to -21807, -319
[22:55:46] Script: Walking to -21788, -317
[22:55:48] Script: Walking to -21767, -321
[22:55:50] Script: Walking to -21760, -316
[22:55:51] Script: Walking to -21759, -293
[22:55:53] Script: Walking to -21759, -270
[22:55:55] Script: Walking to -21759, -236
[22:55:58] Script: Walking to -21759, -214
[22:55:59] Script: Walking to -21759, -192
[22:56:01] Script: Walking to -21759, -172
[22:56:03] Script: Walking to -21759, -147
[22:56:05] Script: Walking to -21759, -107
[22:56:09] Script: Walking to -21759, -77
[22:56:19] Gained 133 experience and 1 SP experience
[22:56:19] Gained 33 job experience
[22:56:19] Quest: [Proof of Strength 2 (Hunter)] has been completed
[22:56:19] Script: Walking to -21759, -77
[22:56:20] Script: Walking to -21759, -107

[22:57:39] Bot stopped. Botting time [5 minutes]

Version 25.2.5 was not doing anything either in job cave. Actually the bot thought it is at the lvl spot right after talking to the NPC (with no effect) and ran straight into the wall x)

I hope this helped a little bit …

Cheers

Can you show me your training position in game? You can use stable on iSRO - I just don’t update it.

Blue circle: Training position, red circle: NPC.
image

Unfortunately, there are no coordinates in the right corner - just ‘sanctum of Red Eye’.

1 Like

You just tested it, too? I did update the path finding in caves so it shouldn’t be making weird paths now.

Jep, this report is brand-new :wink: Tested with the bot version within the link above.

The paths in the version you sent me are alright. Problem is the rewarding and re-accpeting the quest.

Regarding version 25.2.5, there may be some problems concerning paths in cave, that’s true.

1 Like

Paths are made server side so even with an old version they would be fine.

It gets the quest again for me so I do not know what you are doing wrong.

v25.2.5 or v25.2.6?

Both.