Do not switch weapons for buffing v25.5.3

Dear Ryan,
the last version of the bot v25.5.3 the bot do not switch to the secondary weapon in order to buff himself.
for example (wizard/bard, the wizard are not buffing himself with the bard buffs while goes to the spot and also in town script he just don’t switch the weapons and then the bot just stuck if i switch it manually).
please check and fix it.

Set your weapons on the inventory tab.

it was working before the update,all worked well,its just now its stop to switch weapons. after the last update.
before it was working perfect

Nothing has changed with that.

weird the secondary buffs are not working,
before the update it was worked well,
now is v25.5.3 its goes to the spot without swing march and noise.
its just don’t switch to the secondary weapon.
and the weapon in first slot in inventory like always was before.
i don’t know what to say.

i just checked it now,
when i put a buffs for a secondary weapon it will use the secondary buffs ,but it wont switch back to primary weapon.
and the bot will stop and not attack.
please check it

the char buffed himself with secondary buffs,
and after that hes not switching back to primary weapon,
he tries to attack with the secondary weapon which is the wrong weapon and he cant.
he just don’t switch back to the primary weapon after buffed himself with the secondary weapon.
please check it.
thanks Ryan

Most likely you do not have the primary weapon set.

all is set well,it still doesn’t works.
it worked before the update and after the update v25.5.3 it stopped.
please check it Ryan.
or maybe i should just wait till next update maybe it will works.
because its not working now.
thanks anyway Ryan.

update to 25.5.4 … latest update

& delete .json file for that character & re-do all its settings

& keep settings at minimum…
no need to edit ALL options…

ok i will try ,
thanks a lot !

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.