Conditions don't work while botting

For holy water temple and using xAutodungeon I set it to cast a skill after the last unique, then set up a condition to leave party if this skill is active. now if its NOT botting, the condition works fine, but once it starts botting conditions stop working completely.
I even tested this theory by making the bot stop a few seconds after casting the skill, and it doesnt leave party until the bot stops.

is it something in conditions or xAutodungeon plugin or what? … i also tried changing the conditions and adding {if botting && if skill is active}.

@water can u send me a sreenshot of the conditions window


ok i know why becurse botting is not walking in a script botting is just the time at the trainplace actualy atacking (i tested it once wile talking and once while killing mobs while killing it works while walking it dont work ) i will send u a simple solution for this just give me some time

@water3afroto ok there are 2 ways

  1. use a skill that u typicly dont use like the first glavie def skill (pls use the first so u worent leave pt by mistake in the future) and just ust the condition :
    if (Skill active == Bloody Fan Storm) { Leave party: }

  2. use the leave pt data packed in a script i will give it to u but u need 2 plugings for this: xControl and xPackeTool and to update pluging xPluginUpdater by @JellyBitz
    GitHub - JellyBitz/phBot-xPlugins: phBot Plugins - Extend your possibilities using the most advanced SilkroadOnline bot

the data looks like this Client: (Opcode) 0x7061 (Data) None
(u get this with xpacketool )

to trigger it with script just write it like this : inject,0x7061,False,0
( the xControl tool will send it to the server )

so the finsh script should look like this

inject,0x7061,False,0 (this will make u leave pt )

@Chefkoch 1st method is what i tried before, doesnt work for some reason, 2nd one worked very well, thanks alot :smiley:

I’m changing conditions to execute during scripts as well.

@water3afroto pls check again i took the if botting out :smiley:

@Chefkoch if you check the screenshot i sent you, it was the first thing i tired

no ur sreenshot have &&Botting in it thats the mistake

@Chefkoch check the disabled conditions, i tried 3 things, without botting, then botting time>1min, then &&Botting. after a condition failed to work i would disable it and try another one, those were my 3 different attempts.