Bug: Lag detected, waiting

Hello Ryan
the bot have a bug
it stand and do nothing just say Lag detected, waiting but there is no lag , i must press stop start bot and it work normal

u can see here it stand about 12h snd do nothing

[16:34:30] Script: Lag detected, waiting
[17:18:05] Script: Lag detected, waiting
[17:42:50] Script: Lag detected, waiting
[17:45:27] Script: Lag detected, waiting
[18:21:49] Script: Lag detected, waiting
[18:33:17] Script: Lag detected, waiting
[18:49:24] Script: Lag detected, waiting
[18:50:41] Script: Lag detected, waiting
[19:02:59] Script: Lag detected, waiting
[19:03:28] Script: Lag detected, waiting
[19:05:05] Script: Lag detected, waiting
[19:06:30] Script: Lag detected, waiting
[19:26:32] Script: Lag detected, waiting
[19:30:38] Script: Lag detected, waiting
[19:49:39] Script: Lag detected, waiting
[19:50:02] Script: Lag detected, waiting
[20:14:38] Script: Lag detected, waiting
[20:39:17] Script: Lag detected, waiting
[21:14:40] Script: Lag detected, waiting
[21:20:38] Script: Lag detected, waiting
[21:33:52] Script: Lag detected, waiting
[21:35:58] Script: Lag detected, waiting
[21:37:05] Script: Lag detected, waiting
[21:40:40] Script: Lag detected, waiting
[21:44:53] Script: Lag detected, waiting
[22:04:55] Script: Lag detected, waiting
[22:15:40] Script: Lag detected, waiting
[22:16:41] Script: Lag detected, waiting
[23:06:49] Script: Lag detected, waiting
[23:07:58] Script: Lag detected, waiting
[00:01:26] Script: Lag detected, waiting
[00:06:28] Script: Lag detected, waiting
[00:07:43] Script: Lag detected, waiting
[00:09:57] Script: Lag detected, waiting
[00:10:10] Union Party: Accepting union party invite
[00:30:57] Script: Lag detected, waiting
[00:34:48] Script: Lag detected, waiting
[00:56:37] Script: Lag detected, waiting
[01:40:00] Script: Lag detected, waiting
[02:01:57] Script: Lag detected, waiting
[02:12:55] Script: Lag detected, waiting
[02:16:34] Script: Lag detected, waiting
[02:17:55] Script: Lag detected, waiting
[02:54:00] Script: Lag detected, waiting
[02:54:59] Script: Lag detected, waiting
[02:57:41] Script: Lag detected, waiting
[03:25:46] Script: Lag detected, waiting
[04:06:16] Script: Lag detected, waiting
[04:45:49] Script: Lag detected, waiting
[04:56:31] Script: Lag detected, waiting
[04:56:56] Script: Lag detected, waiting

Where? Post the script. I need more info.

it not happen every time

walk,104,32,244
teleport,Hotan,Baghdad
wait,1000
walk,-8522,-748,-236
walk,-8522,-748,-236
walk,-8516,-764,-236
walk,-8512,-775,-236
walk,-8497,-787,-236
walk,-8476,-795,-236
walk,-8471,-806,-236
walk,-8471,-828,-319
walk,-8470,-842,-319
walk,-8470,-852,-319
walk,-8472,-868,-319
walk,-8476,-879,-321
walk,-8477,-890,-355
walk,-8478,-910,-432
walk,-8478,-920,-433
walk,-8478,-928,-433
walk,-8477,-950,-433
walk,-8479,-976,-433
walk,-8479,-998,-433
walk,-8480,-1018,-425
walk,-8483,-1029,-423
walk,-8485,-1050,-432
walk,-8482,-1074,-432
walk,-8481,-1096,-432
walk,-8481,-1116,-432
walk,-8480,-1141,-438
walk,-8477,-1164,-442
walk,-8474,-1184,-440
walk,-8464,-1215,-447
walk,-8453,-1236,-440
walk,-8442,-1258,-437
walk,-8437,-1276,-431
walk,-8437,-1277,-431
walk,-8442,-1290,-432
walk,-8442,-1291,-432
walk,-8463,-1297,-421
walk,-8486,-1309,-425
walk,-8502,-1321,-421
walk,-8516,-1340,-411
walk,-8522,-1350,-382
walk,-8531,-1368,-351
walk,-8536,-1381,-332
walk,-8536,-1398,-330
walk,-8540,-1420,-328
walk,-8549,-1432,-331
walk,-8558,-1448,-334
walk,-8569,-1469,-344
walk,-8579,-1489,-355
walk,-8591,-1502,-353
walk,-8607,-1526,-351
walk,-8624,-1540,-347
walk,-8639,-1548,-347
walk,-8656,-1559,-342
walk,-8671,-1565,-341
walk,-8688,-1570,-338
walk,-8706,-1575,-335
walk,-8726,-1581,-334
walk,-8750,-1588,-329
walk,-8771,-1594,-328
walk,-8782,-1595,-327
walk,-8782,-1595,-327
walk,-8814,-1605,-329
walk,-8834,-1610,-322
walk,-8852,-1616,-314
walk,-8872,-1618,-314
walk,-8872,-1618,-314
walk,-8873,-1617,-313
walk,-8873,-1616,-313
walk,-8873,-1616,-313
walk,-8874,-1615,-312
walk,-8874,-1623,-311
walk,-8874,-1615,-312
walk,-8888,-1625,-308
walk,-8891,-1626,-306
walk,-8898,-1628,-305
walk,-8901,-1630,-303
walk,-8906,-1631,-299
walk,-8963,-1623,-299

That only happens if no packets are received for 12 seconds. In that time it is still trying to walk to the last coordinate but it is still not receiving any packets.

but i can walk in game and if i press stop start bot also walk
can u repair this error?

Is that your full script? I encountered this problem a few hours ago but it was because I was missing a teleport command to get into the job cave. So basically it couldn’t move. Also, if your coordinates are extremely far apart it could cause problems.

Hello admin and community
I sometimes have the same problem.
It occurs when my char teleports to bugdat and occasionally to the gate exits of the city
when this bug appears the only way to intervene is to press manually the start and stop buttons.
The bot by itself is not able to walk again no matter how long you wait.
This is in my opinion a very bad bug because you lose a lot of exp through the long standing.
Sometimes my bot was already standing for days until this was noticed by me.
I sincerely ask you to face this problem with all your competence to fix it.

1 Like

I tested your script and it appears to work fine. I’m not sure what the cause of it could be.

Edit: Here’s a script I generated with path finding. It also appears fine. By the way, path finding wasn’t working with certain Baghdad fields so that’ll work soon.

walk,113,15,0
walk,113,19,0
wait,5000
teleport,Hotan,Baghdad
wait,5000
walk,-8532,-735,0
walk,-8550,-747,0
walk,-8584,-747,0
walk,-8584,-771,0
walk,-8584,-777,0
walk,-8582,-779,0
walk,-8565,-790,0
walk,-8544,-801,0
walk,-8525,-816,0
walk,-8507,-832,0
walk,-8490,-839,0
walk,-8486,-863,0
walk,-8478,-875,0
walk,-8479,-927,0
walk,-8479,-951,0
walk,-8479,-975,0
walk,-8479,-999,0
walk,-8478,-1011,0
walk,-8486,-1045,0
walk,-8486,-1069,0
walk,-8486,-1093,0
walk,-8483,-1102,0
walk,-8482,-1126,0
walk,-8482,-1150,0
walk,-8482,-1174,0
walk,-8482,-1198,0
walk,-8471,-1220,0
walk,-8454,-1237,0
walk,-8449,-1244,0
walk,-8442,-1267,0
walk,-8441,-1274,0
walk,-8450,-1287,0
walk,-8470,-1301,0
walk,-8473,-1302,0
walk,-8490,-1319,0
walk,-8507,-1336,0
walk,-8524,-1353,0
walk,-8541,-1370,0
walk,-8558,-1387,0
walk,-8577,-1402,0
walk,-8594,-1420,0
walk,-8597,-1426,0
walk,-8614,-1443,0
walk,-8623,-1460,0
walk,-8640,-1477,0
walk,-8656,-1496,0
walk,-8673,-1514,0
walk,-8678,-1517,0
walk,-8681,-1518,0
walk,-8684,-1519,0
walk,-8687,-1520,0
walk,-8711,-1520,0
walk,-8734,-1529,0
walk,-8737,-1531,0
walk,-8761,-1531,0
walk,-8785,-1533,0
walk,-8805,-1547,0
walk,-8828,-1554,0
walk,-8849,-1565,0
walk,-8871,-1576,0
walk,-8893,-1587,0
walk,-8914,-1598,0
walk,-8936,-1609,0
walk,-8958,-1620,0
walk,-8963,-1623,0

but admin i not use path finder
normal script use
and the bug not come all time you must bot longer

Why you use normal script if phBot got path finder ?

Unless it occurs consistently I can’t really do anything.

@Denox1337 That area was not working with path finding until now.