Autowalk doesnt work

Hi

Autowalk doesnt work for me. It doesnt matter if iam in Taklamakan or Roc Mt it everytimes shows the message: Script: Unable to generate a script for this location

How i set it?

Go to training place → Get Position → Right Click on the Traning Area + Enable

After finishing town loop it just stop and this Message shows up.

Info: Im not in caves!

Caves are supported. What are your coordinates? If you are close to an obstacle it will not find a path.

Exactly

if you mak get position char wil stay at this geting position … so in town no position know for fight

you need use set coordinate too use autowalk

X -4104,9
Y -435
Z 4

This is near an obstacle but when I was at taklamakan spot I’m sure there was 0 obstacles.

How to set the coordinates exactly? With xyz or only numbers with “,” between the numbers?

-4104, -435

auto

this is example for write coordinate

1 Like

I have done all but still not working.

I have also installed everything new and set also the coords over the Manager on top of that what i have already done.

that -11904, 1519 is your final training place ?
edit: try with the testing version

I have installed now the testing version and tried it again but still nothing happens. I have activated the option “Skip town script entirely” and this was the result:

[23:38:11] Bot started

[23:38:15] Script: No script found, stopping bot

[23:38:15] Bot stopped. Botting time [0 minutes]

For me it looks like the bot needs to generate a script which not works in both versions here. @Ryan any idea?

@jaya final Training place is now -5183, 2545 (Samarkand south so far away from obstacles)

No script found means you have a path set for one but it couldn’t be read. Clear the script.

@ben on your screen the final training area is not same di you right clik on training area set coordinate corectly and ok ? dont activate skipe town
i hop that help you

GM has disabled Auto scripting with PHBot. Thanks for the help!

I don t know exactly how auto scripting works but isn t it an offline function? if so the GM wouldn t have the option to disable u that functionality!

The only way they could prevent that is if they changed all the regions around so the coordinates are different.

Not sure if i should do a new Thread but i have the same problem. (New PHBot user coming from Sbot)
I clicked on “Add” then i tried with “Get Position” and after that with Set Position Coords are:
-12045, 2266 (I tried other spots too)

But everytime the townloop is done the bot stops with:
“Script: No script found, stopping bot”

File Path is empty and also (even its already clear) cleared the Script window.

This is working fine for me so I don’t know what you’re doing wrong.

Yeah… but what? I wrote what i did is there anything i made wrong? Or is there anywhere else a option that has to be turned on for autowalk do work.
I’m using the test version since (Recommended for private servers) and im playing on https://little.town/

Later i will try the Stable version.

  1. Delete your training area.
  2. Create a new one.
  3. Set it as enabled.
  4. Set the coordinates.
  5. Start the bot in town.

If you are not starting it in one of normal iSRO towns then path finding will not work.