Auto Quest FAILED

issue with PHBOT, i was using same script for delivering quest for last month, day to day, nothing changed. Now bot says its bad. After delivering quest is says wrong script. Same happening for other guild member. Whats happening with phbot. I’ve updated it 3 times today. Still doesn’t work.

Why are you using a script to deliver a quest?

When you pressing on quest right buttong, you can set walk script. Which always were working. Char was bringing back quest, taking it again and went back to spot.

How other wise char can deliver back quest in mirror and go back to spot?

It was working same for months, till this happend out of blue.

You don’t need to set a script. You should also post your script so I can actually test it.

120 DOGS REMIXED spot VIRUSAS.txt (3.3 KB) Scrap Metal.txt (969 Bytes)

I have added 1- town script to spot 2- quest script to bring it back to NPC

You may need to add the quest command twice, or you can remove your script and just enable the quest with the “walk back to town” quest turn in option enabled.

I will try to do your way now. But may i ask, whats changed, because my method worked for months…

Were you like 20 versions behind? It’s always in the change log.

I was not, weird thing is that im not alone with this issues which appeared today

There are no quest differences in 25.2.5 and 25.2.4.

What i’ve done now, deleted Jupiter town script from Town folder, and my old method works.

1 Like

If it’s saying it’s the wrong script for the town it means your town script isn’t returning to the center of town spawn.

Have the same Problem
Normaly i used script so i can walk my own way but it isnt working anymore. Also when i put it twice in Script it will not pick up the quest again

Now i tried as you said just enable it and marked the option "walk back to town from your training area to turn in quests
[23:08:55] Auto Quest: Could not generate path to [Smuggler Chao] from [12986.2, -198.4]
[23:08:55] Auto Quest: Disabling quest [Collecting Trade Goods - Western Painting! (Lvl 111-120)]

Those quests are not supported through auto quest because they require you to summon a transport and attack monsters.

Thats why i used a script but the Script doesn´t work anymore
I had to use the workaround from Cempas and deleted the town script for mirror

In the past i could pick it up with script, killed mobs, delivered, make a town repair in mirror and just go back to training area and continue the quest. But not that doesnt work anymore

This will fix not getting the quest if you don’t have it. Quest turn in should have already worked. You do need to put the quest in your script twice.

https://mega.nz/file/n0o01KBa#hvy_XTH0aoq7hQJBsAFvf0Mer4fY74uQ0MdqLV7D_x0

hmm thats not working for me.
Now the bot don´t cast all Training Buffs and also will not cast the transport pet

[19:43:46] Script: Walking to 12887, -31
[19:43:48] Script: Walking to 12885, -20
[19:43:50] Script: Walking to 12882, -13
[19:43:57] Auto Quest: Accepting quest [Collecting Trade Goods - Western Painting! (Lvl 111-120)]
[19:44:09] Script: Walking to 12884, -21
[19:44:10] Script: Walking to 12892, -33
[19:44:13] Script: Walking to 12905, -47

A Part of my Training Script:
walk,12885,-20,-209
walk,12882,-13,-211
quest,Smuggler Road,Collecting Trade Goods - Western Painting! (Lvl 111-120),danger
cast,Job - Merchant Pipe
dismount
wait,2000
walk,12884,-21,-209
walk,12892,-33,-204

And only Fired Shield is buffed when the chars leaves jupiter save zone
image
image
image

It looks like you’re using a script which means you need to cast the job transport skill. Auto quest does not work with the iSRO job transport quests.

Yes thats why i postet a snipped from my script with normaly it cast the transport pet
quest,Smuggler Road,Collecting Trade Goods - Western Painting! (Lvl 111-120),danger
cast,Job - Merchant Pipe
dismount
wait,2000