[23.4.5] Bug: Script equip command not working

I am trying to switch to my shield while walking to my trainings area.

I created the following script for testing purpose.
The equip command isn´t doing anything at all.
vSro 1.188 server
It´s the first time for me trying to use this command, so I don´t know in which version it broke.


equip,Gamri Taegeuk Shield

Hasn’t been changed since it was implemented. Are you sure you typed the name of the shield correctly and that it exists?

Yes, I used the Script Creator to create the script and selected the item in there.
Also I just double checked the spelling. I guess the (+6) doesn´t affect the item name, does it?

No. It only goes by its name. The plus is something separate.

now I also added:
equip,Duke Dress (M)

to the end of the scriot to test if other items are working. It isn´t doing anything as well.

One more updated. I just tested the equip feature of the Inventory tab, this is working properly.
Does it call a different code than the equip of the script command?

Do you already have something equipped in the shield slot? Like arrows or bolts?

Yes, arrows are equipped, since I am using a bow.
Thanks a lot for the quick reply :slight_smile:

Updated: I just unequipped the arrows before running the script. It still doesn´t equip the shield.

1 Like

That’s the cause. I’ll fix it.

1 Like

Great, thank you :slight_smile: Looking forward to the fix

Thanks for the quick fix. Equipping the shield and the bow works now. So I am happy. :slight_smile:
But just wanted to let you know, somehow it is not possible to equip a dress through the command if an other dress is already equipped.
I receive the following message in game:
Cannot equip the selected item

[17:17:33] Script: Setting training area 6851, 1118
[17:17:34] Script: Walking to 6750, 1132
[17:17:35] Script: Walking to 6762, 1131
[17:17:36] Script: Walking to 6773, 1129
[17:17:37] Equip: Equipping [Gamri Taegeuk Shield]
[17:17:39] Script: Walking to 6783, 1127
[17:17:40] Script: Walking to 6795, 1125
[17:17:41] Script: Walking to 6807, 1123
[17:17:42] Script: Walking to 6818, 1121
[17:17:43] Equip: Equipping [Sunaktra]
[17:17:46] Script: Walking to 6829, 1121
[17:17:46] Script: Walking to 6840, 1120
[17:17:47] Script: Walking to 6851, 1118
[17:17:48] Equip: Equipping [Duke Dress (M)]

That’s correct. You’d have to unequip the other dress items because you cannot mix and match most of the time. They have different requirements. I don’t think it’s that big of a deal because there shouldn’t be a need to equip avatar items in a script.

1 Like

Yea, I think so too. :smiley:
Thanks again.

1 Like